1. Si vous venez d'arriver sur le forum et que vous êtes un peu perdus, cliquez ici !
    Rejeter la notice

Bug au lancement de forge 1.12.2

Discussion dans 'Problème avec les mods' créé par Luigi31, 3 Juin 2021.

  1. Luigi31

    Luigi31 Nouveau

    Inscrit:
    3 Juin 2021
    Messages:
    14
    Points:
    0
    Sexe:
    Homme
    Bonjour, avant tout je suis sur Linux. Mon problème est que tout simplement le jeu crash quand je le lance avec forge 1.12.2. Et même minecraft en 1.12.2. Voici l’erreur que j’ai : Le jeu a cessé de fonctionner
    Un problème inattendu est survenu et le jeu a planté. Nous sommes désoler pour la gêne ocasioner.
    Code de sortie : 0

    (je n’ais pas réussi à trouver le rapport du crash. Si quelqu’un le c’est où il se trouve aider moi svp.)
     
  2. robin4002

    robin4002 Support Technique
    Staff

    Inscrit:
    17 Août 2012
    Messages:
    5 414
    Points:
    229
    Sexe:
    Homme
    Bonsoir,

    Forge 1.12.2 ne fonctionne pas avec Java 11 ou 14, il faut Java 8. Hors c'est souvent Java 11 qui est installé sur les distributions Linux.
    Tu es sous quelle distribution Linux ?
     
    • J'approuve J'approuve x 1
  3. Luigi31

    Luigi31 Nouveau

    Inscrit:
    3 Juin 2021
    Messages:
    14
    Points:
    0
    Sexe:
    Homme
    J’ai installer java 8 au lieu de java 11.je vous communique l’es autre info demain
     
  4. Luigi31

    Luigi31 Nouveau

    Inscrit:
    3 Juin 2021
    Messages:
    14
    Points:
    0
    Sexe:
    Homme
    Sa ne marche pas. Mais cette foi j’ai le rapport du crash.( Et juste pour info je n’est pas encore creé de dossier mods) Le voilà:
     

    Fichiers attachés:

  5. robin4002

    robin4002 Support Technique
    Staff

    Inscrit:
    17 Août 2012
    Messages:
    5 414
    Points:
    229
    Sexe:
    Homme
    Le problème de version de Java ne créé pas de crash (car le jeu ne démarre même pas), c'est pour ça que tu n'en avais pas.
    Là on a bien réglé le premier problème mais il y en a un autre, qui concerne l'affichage.

    Tu as plusieurs écrans ? Tu as quelle distribution Linux ?
     
    • J'approuve J'approuve x 1
  6. Luigi31

    Luigi31 Nouveau

    Inscrit:
    3 Juin 2021
    Messages:
    14
    Points:
    0
    Sexe:
    Homme
    Ma distribution est la 20.04lts et je n’ai qu’un seul écran
     
    #6 Luigi31, 4 Juin 2021
    Dernière édition: 4 Juin 2021
  7. Luigi31

    Luigi31 Nouveau

    Inscrit:
    3 Juin 2021
    Messages:
    14
    Points:
    0
    Sexe:
    Homme
    en quoi la distribution linux est'elle-utile?
     
  8. robin4002

    robin4002 Support Technique
    Staff

    Inscrit:
    17 Août 2012
    Messages:
    5 414
    Points:
    229
    Sexe:
    Homme
    Ubuntu 20.04 ?

    Pour avoir une idée des logiciels autours et du type de session graphique notamment. Par défaut Ubuntu 20.04 utilise toujours xorg, donc cela m'étonne d'avoir ce crash. A moins que tu as forcé l'utilisation d'une session avec wayland ?

    (Actuellement Minecraft crash car il ne trouve pas l'écran sur lequel s'afficher. Minecraft 1.12.2 et les versions avant utilise lwjgl 2, qui est assez ancien par rapport à lwjgl 3 utilisé par Minecraft 1.13 et plus récent).
     
    • Informatif Informatif x 1
  9. Luigi31

    Luigi31 Nouveau

    Inscrit:
    3 Juin 2021
    Messages:
    14
    Points:
    0
    Sexe:
    Homme
    donc que doi-je faire?
     
  10. robin4002

    robin4002 Support Technique
    Staff

    Inscrit:
    17 Août 2012
    Messages:
    5 414
    Points:
    229
    Sexe:
    Homme
    • Je désapprouve Je désapprouve x 1
  11. Luigi31

    Luigi31 Nouveau

    Inscrit:
    3 Juin 2021
    Messages:
    14
    Points:
    0
    Sexe:
    Homme
    Sa ne marche pas il me dissent que le paket n’a pas de version susceptible d’être installé
     
  12. Luigi31

    Luigi31 Nouveau

    Inscrit:
    3 Juin 2021
    Messages:
    14
    Points:
    0
    Sexe:
    Homme
    voici le message exact que me donne le terminal :

    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances
    Lecture des informations d'état... Fait
    Aucune version du paquet xrandr n'est disponible, mais il existe dans la base
    de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
    ou qu'il n'est disponible que sur une autre source
    Cependant les paquets suivants le remplacent :
    x11-xserver-utils

    E: Le paquet « xrandr » n'a pas de version susceptible d'être installée
     
  13. robin4002

    robin4002 Support Technique
    Staff

    Inscrit:
    17 Août 2012
    Messages:
    5 414
    Points:
    229
    Sexe:
    Homme
    Donc c'est x11-xserver-utils qu'il faut installer.
     
    • Je désapprouve Je désapprouve x 1
  14. Luigi31

    Luigi31 Nouveau

    Inscrit:
    3 Juin 2021
    Messages:
    14
    Points:
    0
    Sexe:
    Homme
    comment installer x11-xserver-utils ? svp
     
  15. robin4002

    robin4002 Support Technique
    Staff

    Inscrit:
    17 Août 2012
    Messages:
    5 414
    Points:
    229
    Sexe:
    Homme
    pareil, sudo apt install x11-xserver-utils
     

Partager cette page