1. Si vous venez d'arriver sur le forum et que vous êtes un peu perdus, cliquez ici !
    Rejeter la notice

Résolu Problème de permission (PermissionEx)

Discussion dans 'Serveurs' créé par Atayon, 21 Juin 2017.

  1. Atayon

    Atayon Nouveau

    Inscrit:
    20 Juin 2017
    Messages:
    6
    Points:
    0
    Bonjour à tous ? J'espère que vous allez bien.:smile:
    Je rencontre des problèmes avec mon serveur Minecraft qui fonctionne sur Bukkit 1.12.

    Voila je fais des grades pour mon serveur mais je rencontre des problèmes au niveau des permissions. J'utilise PermissionEx pour faire mes grades et pour l'instant je n'ai pas que les grades Fondateur et Builder !:D Mais voila que le grade builder n'a pas accès au deux seules commandes qui lui sont autorisées, c'est-à-dire le gamemode (- essentials.gamemode) et le tp (- essentials.tp). Ce qui me perturbe le plus c'est que se sont les mêmes permissions que j'ai mis pour le Fondateur, à la lettre près.:'(

    Pourriez-vous m'aider à régler mon problème s'il vous plait ? :timide:

    Bonne soirée
     
  2. Touche158

    Touche158 Mineur

    Inscrit:
    26 Oct 2014
    Messages:
    455
    Points:
    91
    Sexe:
    Homme
    Pourrais-tu envoyer tes fichiers de configs ?
     
  3. Atayon

    Atayon Nouveau

    Inscrit:
    20 Juin 2017
    Messages:
    6
    Points:
    0
    Tu pourrais me dire comment faire stp ? (pour mettre les lignes de codes)
     
  4. Touche158

    Touche158 Mineur

    Inscrit:
    26 Oct 2014
    Messages:
    455
    Points:
    91
    Sexe:
    Homme
    Soit tu passe par pastebin et tu copies tous les lignes soit tu les mets entre les balise [ CODE ] et [ /CODE ] (sans les espaces).
     
  5. Atayon

    Atayon Nouveau

    Inscrit:
    20 Juin 2017
    Messages:
    6
    Points:
    0
    Code (cpp):

    multiserver:
      use-netevents: true
    permissions:
      debug: false
      allowOps: false
      user-add-groups-last: true
      log-players: false
      createUserRecords: false
      backend: file
      informplayers:
        changes: false
      basedir: plugins/PermissionsEx
      backends:
        file:
          type: file
          file: permissions.yml
    updater: true
    alwaysUpdate: false


    groups:
      Citoyen:
        options:
          default: true
        permissions:
        - modifyworld.*
      Fondateur:
        options:
          default: false
          build: true
          prefix: '&4'
        permissions:
        - essentials.gamemode
        - essentials.tp
        - essentials.kick
        - essentials.list
        - essentials.whois
        - essentials.feed
        - essentials.feed.others
        - essentials.god
        - essentials.essentials
        - permissions.manage.reload
        - permissions.manage.membership.fondateur
        - permissions.manage.membership.administrateur
        - permissions.manage.membership.modérateur
        - permissions.manage.membership.builder
        - permissions.manage.membership.helper
        - permissions.manage.membership.citoyen
        - permissions.manage.membership.noble
        - permissions.manage.membership.roi
        - permissions.manage.membership.dieux
        - null
      Builder:
        options:
          default: false
          build: true
          prefix: '&b'
        permission:
        - essentials.gamemode
        - essentials.tp
    schema-version: 1
    users:
      62f2f166-37b4-3ce9-a0c2-f7a8e7e858fc:
        group:
        - Builder
        options:
          name: Atayon
     
  6. Touche158

    Touche158 Mineur

    Inscrit:
    26 Oct 2014
    Messages:
    455
    Points:
    91
    Sexe:
    Homme
    Il te manque un s à "permissions" du builder.
     
  7. Atayon

    Atayon Nouveau

    Inscrit:
    20 Juin 2017
    Messages:
    6
    Points:
    0
    Merci beaucoup :smile::smile::smile:
     
  8. Touche158

    Touche158 Mineur

    Inscrit:
    26 Oct 2014
    Messages:
    455
    Points:
    91
    Sexe:
    Homme
    De rien :)
    Je suis là pour aider.
     

Partager cette page