1. Si vous venez d'arriver sur le forum et que vous êtes un peu perdus, cliquez ici !
    Rejeter la notice

Le terraforming et les serveurs passé 1.5

Discussion dans 'Serveurs' créé par tipigeon, 19 Fev 2017.

  1. tipigeon

    tipigeon That's just like...Your opinion man
    Membre Premium

    Inscrit:
    15 Mai 2012
    Messages:
    4 208
    Points:
    234
    Sexe:
    Homme
    Salut à tout ceux qui peuvent m'apporter de l'aide!
    Je n'ai pas joué en serveur local depuis super longtemps, mais récemment j'ai envie de me faire un serveur terraformé à l'ancienne avec world edit et voxel sniper.
    Problème, beaucoup de choses ont changé!
    Je suis perdu entre spigot et bukkit et bungy et sponge et machin truc et bidule...
    J'aurais besoin que quelqu'un m'explique comment set up un serveur privé en 1.9 1.10 ou 1.11 avec world edit et voxel, ce serait vachement cool de votre part!
     
  2. CactusKipic

    CactusKipic Bûcheron

    Inscrit:
    28 Oct 2015
    Messages:
    124
    Points:
    56
    Sexe:
    Homme
    Salut,

    Le moyen le plus simple pour mettre en place un serveur en local, est de télécharger une version de Bukkit ou Spigot sur GetBukkit, je te conseille Spigot, c'est un dérivé de Bukkit qui tend à être plus optimisé. Les plugins fonctionnant aussi bien sur Bukkit que Spigot. Pour ce qui est de la setup, elle est extrêmement simple, il suffit de placer le '.jar' dans le dossier du serveur et de créer un '.bat' (communément 'start.bat') effectuant le lancement du serveur:

    Code (cpp):
    @echo off

    java -Xms512M -Xmx1024M -jar spigot.jar
    pause
    La commande lancera le serveur, et tu auras une fenêtre avec les logs. C'est aussi avec cette commande que tu règles la RAM du serveur. Ici 'spigot.jar' étant le nom du '.jar' de ton serveur. Pour la RAM, '-Xms***' représente la RAM au lancement du serveur, et '-Xmx****' la RAM limite pouvant être utilisée par le serveur.

    Au premier lancement le serveur te demandera d'accepter l'EULA, il faudra ouvrir le fichier 'eula.txt' et changer la valeur de 'eula' de 'false' à 'true'. Ensuite une fois le serveur relancé il générera le monde 'world' et ajoutera tous les fichiers et dossiers nécessaires dans le dossier du serveur, notamment le dossier 'plugins'.

    Et enfin pour ce qui est des plugins il faut aller les chercher soit sur DevBukkit ou sur SpigotMC, c'est les deux principales sources sûre pour les plugins.
     
    #2 CactusKipic, 19 Fev 2017
    Dernière édition: 19 Fev 2017
  3. tipigeon

    tipigeon That's just like...Your opinion man
    Membre Premium

    Inscrit:
    15 Mai 2012
    Messages:
    4 208
    Points:
    234
    Sexe:
    Homme
    Merci bon par contre j'ai un nouveau problème, ca me dit "invalid or corrupt jarfile spigot.jar"
     
  4. CactusKipic

    CactusKipic Bûcheron

    Inscrit:
    28 Oct 2015
    Messages:
    124
    Points:
    56
    Sexe:
    Homme
    Étonnant, à priori il n'y a pas de raison pour que le 'jar' soit corrompu. Mais si tu as cette erreur ça doit être vrai, donc essaye de retélécharger le 'jar', sinon tente une autre version.
    Et je viens de lancer un serveur en 1.11.2 (ce que je n'avais encore jamais fait) et apparemment la commande n'est pas 'juste' pour la dernière version de Java, je vais donc rectifié ça dans le message juste avant (même si cela n'empêche pas le lancement du serveur en 1.11.2).
     
  5. tipigeon

    tipigeon That's just like...Your opinion man
    Membre Premium

    Inscrit:
    15 Mai 2012
    Messages:
    4 208
    Points:
    234
    Sexe:
    Homme
    D'accord c'est étrange j'ai re dl le spigot et ca refait le meme message d'erreur
     
  6. CactusKipic

    CactusKipic Bûcheron

    Inscrit:
    28 Oct 2015
    Messages:
    124
    Points:
    56
    Sexe:
    Homme
    J'avouerai que j'ai du mal à voir ce qui pourrait poser problème. Tu as téléchargé la dernière version de Spigot (1.11.2) ?
    Car personnellement je viens de télécharger la dernière version et avec un .bat comme suit:

    Code (cpp):
    @echo off

    java -Xms512M -Xmx1024M -jar spigot.jar
    pause
    Je n'ai aucune erreur :/
    L'erreur dans la commande étant juste la partie '-XX: ***' qui était devenu inutile, mais le serveur se lançait quand même.

    Edit: Je crois que j'ai la solution du problème, ça viendrait d'un problème de téléchargement avec le site:
    [​IMG]
    Il faudrait donc télécharger le fichier avec Chrome, ça devrait marcher avec Opéra aussi étant donné qu'ils sont tous deux basé sur Chromium.
     
    • Informatif Informatif x 1
    #6 CactusKipic, 19 Fev 2017
    Dernière édition: 19 Fev 2017
  7. tipigeon

    tipigeon That's just like...Your opinion man
    Membre Premium

    Inscrit:
    15 Mai 2012
    Messages:
    4 208
    Points:
    234
    Sexe:
    Homme
    Bon j'ai essayé deux trois fois avec chrome mais c'est encore beuggué, je vais attendre un peu je verrais la semaine pro
     

Partager cette page