1. Si vous venez d'arriver sur le forum et que vous êtes un peu perdus, cliquez ici !
    Rejeter la notice

Résolu Pb de serveurs multi monde

Discussion dans 'Serveurs' créé par Tiopatch, 15 Jan 2017.

  1. Tiopatch

    Tiopatch Nouveau

    Inscrit:
    15 Jan 2017
    Messages:
    5
    Points:
    0
    Sexe:
    Homme
    Bonjour à tous,

    Je viens ici demander de l'aide aux génies minecraftiens, car moi depuis 8 jours sur le problème je commence à perdre patience !

    J'ai créé un petit serveur chez moi pour jouer avec mes enfants.
    je voulais créer un monde Skyblock pour se lancer un défi ...

    Malheureusement, j'ai réussi a créer le serveur, mais le reste est beaucoup plus compliqué !

    j'ai installé les plugins suivants :
    Multiverse_core 2.5
    Multiverse_portal 2.4
    Multiverse_inventories 2.5
    vault

    alors j'arrive à créer un nouveau monde, mais quand je veux créer le portail, ca me met une erreur (an internal error ...)

    J'ai lu pleins de choses sur ce probleme sans trouver de solution, je ne suis pas fort avec l'Anglais et les vidéos youtube, bah je comprend rien.

    et la je sèche de toute solution.

    Je suis sur un serveur spigot 1.11.2

    Voila, j'en appel a vos bonnes volonté pour m'aider :) merci
     
  2. CactusKipic

    CactusKipic Bûcheron

    Inscrit:
    28 Oct 2015
    Messages:
    124
    Points:
    56
    Sexe:
    Homme
    Pour pouvoir trouver ce qui ne va pas il nous faudrait l'erreur qui se trouve dans les logs (dossier 'logs' dans le dossier du serveur). Sans ça, compliqué de dire quel est le problème :/
     
  3. Tiopatch

    Tiopatch Nouveau

    Inscrit:
    15 Jan 2017
    Messages:
    5
    Points:
    0
    Sexe:
    Homme
    Bonsoir,

    désolé pour le temps de réponse,
    voici le log du serveur lors de l'erreur :

    Code (cpp):
    [19:13:42 INFO]: Preparing spawn area for skyblock, 40%
    [19:13:43 INFO]: [Multiverse-Core] 4 - World(s) loaded.
    [19:13:43 INFO]: [Multiverse-Core] Version 2.5-b719 (API v20) Enabled - By Rigby, fernferret, lithium3141 and main--
    [19:13:43 INFO]: [Multiverse-Portals] Enabling Multiverse-Portals v2.4-b548
    [19:13:43 INFO]: [Multiverse-Portals] - Version 2.4-b548 Enabled - By Rigby and fernferret
    [19:13:43 INFO]: [Multiverse-Portals]  0 - Portals(s) loaded
    [19:13:43 INFO]: [Multiverse-Inventories] Enabling Multiverse-Inventories v2.5-b412
    [19:13:43 INFO]: [Multiverse-Inventories 2.5-b412] enabled.
    [19:13:43 WARN]: Server permissions file permissions.yml is not valid YAML.
    org.yaml.snakeyaml.error.YAMLException: java.nio.charset.MalformedInputException: Input length = 1
      at org.yaml.snakeyaml.reader.StreamReader.update(StreamReader.java:200) ~[spigot.jar:git-Spigot-7d78b81-70bc70b]
      at org.yaml.snakeyaml.reader.StreamReader.<init>(StreamReader.java:60) ~[spigot.jar:git-Spigot-7d78b81-70bc70b]
      at org.yaml.snakeyaml.Yaml.load(Yaml.java:381) ~[spigot.jar:git-Spigot-7d78b81-70bc70b]
      at org.bukkit.craftbukkit.v1_11_R1.CraftServer.loadCustomPermissions(CraftServer.java:782) [spigot.jar:git-Spigot-7d78b81-70bc70b]
      at org.bukkit.craftbukkit.v1_11_R1.CraftServer.enablePlugins(CraftServer.java:336) [spigot.jar:git-Spigot-7d78b81-70bc70b]
      at net.minecraft.server.v1_11_R1.MinecraftServer.t(MinecraftServer.java:419) [spigot.jar:git-Spigot-7d78b81-70bc70b]
      at net.minecraft.server.v1_11_R1.MinecraftServer.l(MinecraftServer.java:380) [spigot.jar:git-Spigot-7d78b81-70bc70b]
      at net.minecraft.server.v1_11_R1.MinecraftServer.a(MinecraftServer.java:335) [spigot.jar:git-Spigot-7d78b81-70bc70b]
      at net.minecraft.server.v1_11_R1.DedicatedServer.init(DedicatedServer.java:272) [spigot.jar:git-Spigot-7d78b81-70bc70b]
      at net.minecraft.server.v1_11_R1.MinecraftServer.run(MinecraftServer.java:542) [spigot.jar:git-Spigot-7d78b81-70bc70b]
      at java.lang.Thread.run(Unknown Source) [?:1.8.0_111]
    Caused by: java.nio.charset.MalformedInputException: Input length = 1
      at java.nio.charset.CoderResult.throwException(Unknown Source) ~[?:1.8.0_111]
      at sun.nio.cs.StreamDecoder.implRead(Unknown Source) ~[?:1.8.0_111]
      at sun.nio.cs.StreamDecoder.read(Unknown Source) ~[?:1.8.0_111]
      at java.io.InputStreamReader.read(Unknown Source) ~[?:1.8.0_111]
      at org.yaml.snakeyaml.reader.UnicodeReader.read(UnicodeReader.java:123) ~[spigot.jar:git-Spigot-7d78b81-70bc70b]
      at java.io.Reader.read(Unknown Source) ~[?:1.8.0_111]
      at org.yaml.snakeyaml.reader.StreamReader.update(StreamReader.java:184) ~[spigot.jar:git-Spigot-7d78b81-70bc70b]
      ... 10 more
    [19:13:43 INFO]: Done (6,367s)! For help, type "help" or "?"
    [19:13:43 INFO]: [Vault] Checking for Updates ...
    [19:13:44 INFO]: [Vault] No new version available
    [19:14:51 INFO]: UUID of player Tiopatch is 4b8aa966-1fd6-4409-9049-c039e50516ed
    [19:14:52 INFO]: Tiopatch[/127.0.0.1:65165] logged in with entity id 417 at ([test]-72.77341479377831, 71.0, 304.667445214464)
    [19:15:01 INFO]: Tiopatch issued server command: /gamemode creative
    [19:15:01 INFO]: [Tiopatch: Set own game mode to Creative Mode]
    [19:15:06 INFO]: Tiopatch issued server command: /time set day
    [19:15:06 INFO]: [Tiopatch: Set the time to 1000]
    [19:15:36 INFO]: Tiopatch issued server command: /mvpcreate
    [19:15:48 INFO]: Tiopatch issued server command: /mvpcreate gate1 gate2
    [19:15:48 ERROR]: null
    org.bukkit.command.CommandException: Unhandled exception executing command 'mvpcreate' in plugin Multiverse-Portals v2.4-b548
      at org.bukkit.command.PluginCommand.execute(PluginCommand.java:46) ~[spigot.jar:git-Spigot-7d78b81-70bc70b]
      at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141) ~[spigot.jar:git-Spigot-7d78b81-70bc70b]
      at org.bukkit.craftbukkit.v1_11_R1.CraftServer.dispatchCommand(CraftServer.java:649) ~[spigot.jar:git-Spigot-7d78b81-70bc70b]
      at net.minecraft.server.v1_11_R1.PlayerConnection.handleCommand(PlayerConnection.java:1344) [spigot.jar:git-Spigot-7d78b81-70bc70b]
      at net.minecraft.server.v1_11_R1.PlayerConnection.a(PlayerConnection.java:1179) [spigot.jar:git-Spigot-7d78b81-70bc70b]
      at net.minecraft.server.v1_11_R1.PacketPlayInChat.a(PacketPlayInChat.java:45) [spigot.jar:git-Spigot-7d78b81-70bc70b]
      at net.minecraft.server.v1_11_R1.PacketPlayInChat.a(PacketPlayInChat.java:1) [spigot.jar:git-Spigot-7d78b81-70bc70b]
      at net.minecraft.server.v1_11_R1.PlayerConnectionUtils$1.run(SourceFile:13) [spigot.jar:git-Spigot-7d78b81-70bc70b]
      at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) [?:1.8.0_111]
      at java.util.concurrent.FutureTask.run(Unknown Source) [?:1.8.0_111]
      at net.minecraft.server.v1_11_R1.SystemUtils.a(SourceFile:46) [spigot.jar:git-Spigot-7d78b81-70bc70b]
      at net.minecraft.server.v1_11_R1.MinecraftServer.D(MinecraftServer.java:739) [spigot.jar:git-Spigot-7d78b81-70bc70b]
      at net.minecraft.server.v1_11_R1.DedicatedServer.D(DedicatedServer.java:399) [spigot.jar:git-Spigot-7d78b81-70bc70b]
      at net.minecraft.server.v1_11_R1.MinecraftServer.C(MinecraftServer.java:675) [spigot.jar:git-Spigot-7d78b81-70bc70b]
      at net.minecraft.server.v1_11_R1.MinecraftServer.run(MinecraftServer.java:574) [spigot.jar:git-Spigot-7d78b81-70bc70b]
      at java.lang.Thread.run(Unknown Source) [?:1.8.0_111]
    Caused by: java.lang.NoSuchMethodError: org.bukkit.Server.getOnlinePlayers()[Lorg/bukkit/entity/Player;
      at com.onarandombox.MultiversePortals.MVPortal.addToUpperLists(MVPortal.java:157) ~[?:?]
      at com.onarandombox.MultiversePortals.MVPortal.init(MVPortal.java:92) ~[?:?]
      at com.onarandombox.MultiversePortals.MVPortal.<init>(MVPortal.java:61) ~[?:?]
      at com.onarandombox.MultiversePortals.MVPortal.<init>(MVPortal.java:219) ~[?:?]
      at com.onarandombox.MultiversePortals.utils.PortalManager.addPortal(PortalManager.java:126) ~[?:?]
      at com.onarandombox.MultiversePortals.commands.CreateCommand.runCommand(CreateCommand.java:62) ~[?:?]
      at com.pneumaticraft.commandhandler.multiverse.CommandHandler.checkAndRunCommand(CommandHandler.java:279) ~[?:?]
      at com.pneumaticraft.commandhandler.multiverse.CommandHandler.processFoundCommands(CommandHandler.java:143) ~[?:?]
      at com.pneumaticraft.commandhandler.multiverse.CommandHandler.locateAndRunCommand(CommandHandler.java:93) ~[?:?]
      at com.pneumaticraft.commandhandler.multiverse.CommandHandler.locateAndRunCommand(CommandHandler.java:71) ~[?:?]
      at com.onarandombox.MultiversePortals.MultiversePortals.onCommand(MultiversePortals.java:317) ~[?:?]
      at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44) ~[spigot.jar:git-Spigot-7d78b81-70bc70b]
      ... 15 more
    Et je comprends pas , est ce que ca vient de spigot ? mais bukkit j'y arrive pas a lancer le serveur

    merci par avance .
     
    #3 Tiopatch, 16 Jan 2017
    Dernière édition par un modérateur: 18 Jan 2017
  4. Tiopatch

    Tiopatch Nouveau

    Inscrit:
    15 Jan 2017
    Messages:
    5
    Points:
    0
    Sexe:
    Homme
    je rajoute qu'avec la hache en bois, je fais un clic gauche sur le bloc bas gauche du portail, et un clic droit sur le bloc haut droit. (la j'ai deux écriture avec le clic droit alors qu'une avec le gauche) et avec multiverse portal, je fais /mvp create gate1 gate2 et la j'ai le message d'erreur
     
  5. CactusKipic

    CactusKipic Bûcheron

    Inscrit:
    28 Oct 2015
    Messages:
    124
    Points:
    56
    Sexe:
    Homme
    Ça à l'air d'être un problème de compatibilité (au niveau de la version), et je vois que tu as la version v2.4-b548 et il a une version plus récente de dispo sur la page du plugin. Elle devrait sûrement résoudre le problème, si ce n'est pas le cas il faudra trouver un autre plugin de création de portail (il n'y a pas de problème de compatibilité entre les plugins de gestion de monde et de portail à priori).

    Et deux petites remarque au niveau des messages, il serait mieux de mettre l'erreur dans des balises de code (dans le '+' lors de l'édition) et les doubles post sont interdit, il aurait donc fallu que tu utilises la fonction d’édition sur ton premier message.
     
  6. Tiopatch

    Tiopatch Nouveau

    Inscrit:
    15 Jan 2017
    Messages:
    5
    Points:
    0
    Sexe:
    Homme
    Merci cactus, désolé pour les balises et le double post ! merci pour les précisions d'usages :)
    Je reviens éditer ce message quand j'aurais fait les essais :)

    [EDIT] Super ! ça marche ! merci cactus !

    Je me permet de faire une petite demande de rien du tout, sur le serveur, si les joueurs ne sont pas /op, alors ils ne peuvent pas détruire les blocs ? pourquoi donc ?

    encore merci
     
    #6 Tiopatch, 17 Jan 2017
    Dernière édition: 17 Jan 2017
  7. CactusKipic

    CactusKipic Bûcheron

    Inscrit:
    28 Oct 2015
    Messages:
    124
    Points:
    56
    Sexe:
    Homme
    Vu les plugins que tu as d'installé, hormis la protection du spawn il n'y a pas de raison que les joueur non OP ne puisse casser les blocs. Si tu es sur un monde Skyblock il y a des chances pour que l'île de départ soit totalement dans la zone protégée du spawn, pour la supprimer il faut aller dans le 'serveur.properties' dans le dossier du serveur et passer 'spawn-protection' à 0 (normalement à la ligne 3).
    J'espère que ça réglera ton problème.
     
  8. Tiopatch

    Tiopatch Nouveau

    Inscrit:
    15 Jan 2017
    Messages:
    5
    Points:
    0
    Sexe:
    Homme
    Oui tout a fait cactus, j'ai installer permissionbukkit, car sinon les joueurs non op ne pouvait pas traverser le portail inter monde que j'avais mis en place .
    J'ai installé le plugin Askybloc également mais malheureusement, une fois qu'on rentre dedans on ne peut pas en sortir, ce qui est dommage !
    mais merci pour tes bons conseils cactus :) très sympa !
     

Partager cette page