1. Si vous venez d'arriver sur le forum et que vous êtes un peu perdus, cliquez ici !
    Rejeter la notice

Résolu Plantage du launcher de Minecraft sous Forge 1.12.2

Discussion dans 'Problème avec les mods' créé par Babaille, 17 Avr 2020.

  1. Babaille

    Babaille Nouveau

    Inscrit:
    17 Avr 2020
    Messages:
    9
    Points:
    0
    Sexe:
    Homme
    Bonjour,
    Je joue à Minecraft sur un PC Lenovo tournant sous Linux Mint
    Le launcher fonctionne parfaitement en mode normal ainsi qu'en Forge 1.15.2
    Par contre, lorsque j'essaie d'installer aussi la version Forge 1.12.2 sur laquelle on trouve plusieurs mods qui m'intéressent et ne sont pas (encore) adaptés à la version 1.15.2, le launcher plante en indiquant :
    Erreur le jeu a cessé de fonctionner - Un problème inattendu est survenu et le jeu a planté. Nous sommes désolés pour la gêne occasionnée.
    Aucun bouton ne s'affiche pour récupérer un message d'erreur
    Je copie donc ci-dessous le lastlog que j'ai récupéré dans .minecraft juste après la dernière tentative de connexion avortée.

    La version précise de Forge est 1.12.2-Forge1.12.2-14.23.5.2768
    Elle a été récupérée sur le site Forge Officiel
    Dans Telechargement j'ai autorisé l'exécution du fichier .jar en allant dans propriété
    J'ai ensuite double cliqué dessus et choisi l'installation client qui semble s'effectuer normalement (c'est très rapide par contre je ne sais pas si c'est normal)

    La version Forge 1.12.2 n'apparaît pas immédiatement dans les choix du launcher il a fallu aller sur configurations pour la trouver et l'afficher.

    Merci de votre aide pour comprendre ce qui ne fonctionne pas.

    Cut/Paste du log supprimé puisqu'il était inutile
     
    #1 Babaille, 17 Avr 2020
    Dernière édition: 17 Avr 2020
  2. robin4002

    robin4002 Support Technique
    Staff

    Inscrit:
    17 Août 2012
    Messages:
    5 220
    Points:
    229
    Sexe:
    Homme
    Bonjour,
    Le logs que tu as envoyé ne contient aucune trace de forge.

    Assures-toi t'envoyer le contenu du fichier latest.log, juste après avoir lancé le profil forge.
     
    • Sympa Sympa x 1
  3. Babaille

    Babaille Nouveau

    Inscrit:
    17 Avr 2020
    Messages:
    9
    Points:
    0
    Sexe:
    Homme
    Désolé le cut/paste était incomplet. Le voici en entier :

    Cut/paste du log supprimé puisqu'il était inutile
     
    #3 Babaille, 17 Avr 2020
    Dernière édition: 17 Avr 2020
  4. robin4002

    robin4002 Support Technique
    Staff

    Inscrit:
    17 Août 2012
    Messages:
    5 220
    Points:
    229
    Sexe:
    Homme
    C'est toujours pas bon.
    Dans ce log c'est une partie en jeu sans mods, sans forge.

    Supprimes tous le dossier logs, lances le jeu avec forge, puis envoies le fichier latest.log directement après (sans relancer le jeu sans forge).
     
    • Sympa Sympa x 1
  5. Babaille

    Babaille Nouveau

    Inscrit:
    17 Avr 2020
    Messages:
    9
    Points:
    0
    Sexe:
    Homme
    J'ai déplacé tous le contenu de mon dossier log de .minecraft dans un dossier temporaire sur le bureau.
    Le dossier log est donc vide.

    Je lance ensuite le launcher en sélectionnant Forge 1.12.2 et il plante comme d'habitude. Ensuite en regardant dans Log je constate qu'aucun log ne s'est créé. Pour information le plantage se fait tout au début du lancement. La barre verte "préparation en cours" commence tout juste à se remplir (un demi centimètre) puis la page minecraft d'affiche et plante tout de suite.

    J'ai relancé le launcher sous Forge 1.15.2 et là cela fonctionne et le log se crée correctement (voir ci-dessous).

    [17avr.2020 17:44:07.811] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--username, azik_pvp, --version, 1.15.2-forge-31.1.0, --gameDir, /home/bayan/.minecraft, --assetsDir, /home/bayan/.minecraft/assets, --assetIndex, 1.15, --uuid, 27d3c7145f814a85bef6c494fa389eff, --accessToken, ❄❄❄❄❄❄❄❄, --userType, mojang, --versionType, release, --launchTarget, fmlclient, --fml.forgeVersion, 31.1.0, --fml.mcVersion, 1.15.2, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20200122.131323]
    [17avr.2020 17:44:07.828] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 5.0.0-milestone.4+67+b1a340b starting: java version 11.0.6 by Ubuntu
    [17avr.2020 17:44:08.915] [main/INFO] [net.minecraftforge.fml.loading.FixSSL/CORE]: Added Lets Encrypt root certificates as additional trust
    [17avr.2020 17:44:10.386] [main/INFO] [STDERR/]: [jdk.nashorn.api.scripting.NashornScriptEngine:<init>:143]: Warning: Nashorn engine is planned to be removed from a future JDK release
    [17avr.2020 17:44:11.362] [main/INFO] [cpw.mods.modlauncher.LaunchServiceHandler/MODLAUNCHER]: Launching target 'fmlclient' with arguments [--version, 1.15.2-forge-31.1.0, --gameDir, /home/bayan/.minecraft, --assetsDir, /home/bayan/.minecraft/assets, --uuid, 27d3c7145f814a85bef6c494fa389eff, --username, azik_pvp, --assetIndex, 1.15, --accessToken, ❄❄❄❄❄❄❄❄, --userType, mojang, --versionType, release]
    [17avr.2020 17:44:16.304] [Render thread/INFO] [net.minecraft.client.Minecraft/]: Setting user: azik_pvp
    [17avr.2020 17:44:32.023] [Render thread/INFO] [net.minecraft.client.Minecraft/]: Backend library: LWJGL version 3.2.2 build 10
    [17avr.2020 17:44:34.148] [modloading-worker-1/INFO] [net.minecraftforge.common.ForgeMod/FORGEMOD]: Forge mod loading, version 31.1.0, for MC 1.15.2 with MCP 20200122.131323
    [17avr.2020 17:44:34.152] [modloading-worker-1/INFO] [net.minecraftforge.common.MinecraftForge/FORGE]: MinecraftForge v31.1.0 Initialized
    [17avr.2020 17:44:35.961] [Render thread/WARN] [net.minecraft.resources.ResourcePackInfo/]: Couldn't get pack info for: java.util.zip.ZipException: zip file is empty
    [17avr.2020 17:44:36.206] [Render thread/WARN] [net.minecraft.resources.ResourcePackInfo/]: Couldn't get pack info for: net.minecraft.resources.ResourcePackFileNotFoundException: 'pack.mcmeta' in ResourcePack '/home/bayan/.minecraft/resourcepacks/Chocapic13_V8_Ultra.zip'
    [17avr.2020 17:44:36.307] [Render thread/WARN] [net.minecraft.resources.ResourcePackInfo/]: Couldn't get pack info for: java.util.zip.ZipException: zip file is empty
    [17avr.2020 17:44:36.357] [Render thread/WARN] [net.minecraft.resources.ResourcePackInfo/]: Couldn't get pack info for: net.minecraft.resources.ResourcePackFileNotFoundException: 'pack.mcmeta' in ResourcePack '/home/bayan/.minecraft/resourcepacks/Chocapic13_V8_Ultra.zip'
    [17avr.2020 17:44:40.282] [Render thread/INFO] [com.mojang.text2speech.NarratorLinux/]: Narrator library successfully loaded
    [17avr.2020 17:44:40.426] [Render thread/INFO] [net.minecraft.resources.SimpleReloadableResourceManager/]: Reloading ResourceManager: Mod Resources, Default, Programmer Art
    [17avr.2020 17:45:06.350] [Forge Version Check/INFO] [net.minecraftforge.fml.VersionChecker/]: [forge] Starting version check at https://files.minecraftforge.net/maven/net/minecraftforge/forge/promotions_slim.json
    [17avr.2020 17:45:09.079] [Forge Version Check/INFO] [net.minecraftforge.fml.VersionChecker/]: [forge] Found status: UP_TO_DATE Current: 31.1.0 Target: null
    [17avr.2020 17:45:17.669] [Render thread/INFO] [net.minecraft.client.audio.SoundSystem/]: OpenAL initialized.
    [17avr.2020 17:45:17.691] [Render thread/INFO] [net.minecraft.client.audio.SoundEngine/SOUNDS]: Sound engine started
    [17avr.2020 17:45:17.993] [Render thread/INFO] [net.minecraft.client.renderer.texture.AtlasTexture/]: Created: 1024x512x4 minecraft:textures/atlas/blocks.png-atlas
    [17avr.2020 17:45:18.025] [Render thread/INFO] [net.minecraft.client.renderer.texture.AtlasTexture/]: Created: 128x128x4 minecraft:textures/atlas/signs.png-atlas
    [17avr.2020 17:45:18.026] [Render thread/INFO] [net.minecraft.client.renderer.texture.AtlasTexture/]: Created: 512x512x4 minecraft:textures/atlas/banner_patterns.png-atlas
    [17avr.2020 17:45:18.029] [Render thread/INFO] [net.minecraft.client.renderer.texture.AtlasTexture/]: Created: 512x512x4 minecraft:textures/atlas/shield_patterns.png-atlas
    [17avr.2020 17:45:18.032] [Render thread/INFO] [net.minecraft.client.renderer.texture.AtlasTexture/]: Created: 256x256x4 minecraft:textures/atlas/chest.png-atlas
    [17avr.2020 17:45:18.033] [Render thread/INFO] [net.minecraft.client.renderer.texture.AtlasTexture/]: Created: 512x256x4 minecraft:textures/atlas/beds.png-atlas
    [17avr.2020 17:45:18.034] [Render thread/INFO] [net.minecraft.client.renderer.texture.AtlasTexture/]: Created: 512x256x4 minecraft:textures/atlas/shulker_boxes.png-atlas
    [17avr.2020 17:45:19.244] [Render thread/INFO] [net.minecraft.client.renderer.texture.AtlasTexture/]: Created: 256x256x0 minecraft:textures/atlas/particles.png-atlas
    [17avr.2020 17:45:19.247] [Render thread/INFO] [net.minecraft.client.renderer.texture.AtlasTexture/]: Created: 256x256x0 minecraft:textures/atlas/paintings.png-atlas
    [17avr.2020 17:45:19.248] [Render thread/INFO] [net.minecraft.client.renderer.texture.AtlasTexture/]: Created: 128x128x0 minecraft:textures/atlas/mob_effects.png-atlas
    [17avr.2020 17:45:27.748] [Render thread/INFO] [net.minecraft.client.Minecraft/]: Stopping!
     
  6. robin4002

    robin4002 Support Technique
    Staff

    Inscrit:
    17 Août 2012
    Messages:
    5 220
    Points:
    229
    Sexe:
    Homme
    Ok trouvé et ça explique aussi pourquoi tu n'as pas de log.
    Désinstalles Java 11 et installes Java 8.

    Les anciennes versions de Forge ne gère pas Java 11.
     
  7. Babaille

    Babaille Nouveau

    Inscrit:
    17 Avr 2020
    Messages:
    9
    Points:
    0
    Sexe:
    Homme
    Merci
    Par contre je viens de faire la modification de la version de Java et le launcher ne se lance plus du tout : il plante directement à l'ouverture en donnant ce message : "erreur lors du lancement de l'application"
    La version de java installée est la suivante (commande java -version)

    openjdk version "1.8.0_242"
    OpenJDK Runtime Environment (build 1.8.0_242-8u242-b08-0ubuntu3-18.04-b08)
    OpenJDK 64-Bit Server VM (build 25.242-b08, mixed mode)

    Y-a-t-il une étape que j'ai manquée ?
     
  8. robin4002

    robin4002 Support Technique
    Staff

    Inscrit:
    17 Août 2012
    Messages:
    5 220
    Points:
    229
    Sexe:
    Homme
    Le launcher ne se lance pas ?
    C'est étrange, le launcher n'a pas besoin de Java ... Essaies de le réinstaller.
     
  9. Babaille

    Babaille Nouveau

    Inscrit:
    17 Avr 2020
    Messages:
    9
    Points:
    0
    Sexe:
    Homme
    Je viens de le tenter mais lorsque je tente de réinstaller le launcher une fenêtre pop-up apparaît disant cela :

    Des logiciels supplémentaires doivent être installés

    Veuillez consulter la liste des changements ci-dessous.
    85.7M octets seront téléchargés au total.
    163.3M octets d'espace disque supplémentaire seront utilisés.

    default-jre-headless=2:1.11-68ubuntu1-18.04.1
    default-jre=2:1.11-68ubuntu1-18.04.1
    libpangox-1.0.0=0.0.2-5
    libpango1.0-0=1.40.14-1ubuntu0.1
    openjdk-11-jre-headless=11.0.6+10-1ubuntu1~18.04.1
    openjdk-11-jre=11.0.6+10-1ubuntu1~18.04.1

    J'ai l'impression que le launcher qui est préinstallé sur ma version de Mint ne tourne pas sans java 11. Du coup dois-je télécharger une autre version du launcher pour installer Forge 1.12.2 ?

    Merci
     
  10. robin4002

    robin4002 Support Technique
    Staff

    Inscrit:
    17 Août 2012
    Messages:
    5 220
    Points:
    229
    Sexe:
    Homme
    Ah bon réinstalles Java 11 dans ce cas.
    Une fois que le launcher s'ouvrira à nouveau, dans les options de configuration de forge, puis dans plus d'options tu pourras mettre le chemin de Java :
    upload_2020-4-18_0-45-51.png

    Le chemin est surement /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java

    Tu peux utiliser la commande
    update-alternatives --list java
    pour trouver le chemin.
     
  11. Babaille

    Babaille Nouveau

    Inscrit:
    17 Avr 2020
    Messages:
    9
    Points:
    0
    Sexe:
    Homme
    Cela a fonctionné ; merci beaucoup
     
  12. Rafafa8

    Rafafa8 Nouveau

    Inscrit:
    16 Mai 2020
    Messages:
    7
    Points:
    0
    Sexe:
    Homme
    Bonjour, j'ai eu le même problème et j'ai suivi les étapes ci-dessus, mais malheureusement j'ai encore un souci :
    quand je lance la version 1.8.9 après avoir mis manuellement le JAVA executable, ça me remet un message d'erreur disant

    Unable to locate the Java runtime.
    Error details: Succès
    Filename on disk: java
    Path: /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java
    Exists: Nonexistent

    voila, j'espère que vous pouvez continuer d'aider a résoudre ce problème.
     
  13. robin4002

    robin4002 Support Technique
    Staff

    Inscrit:
    17 Août 2012
    Messages:
    5 220
    Points:
    229
    Sexe:
    Homme
    Bonsoir,
    Soit java 8 n'est pas installé, soit-il n'est pas à l'endroit indiqué.
    Tu utilises quelle distribution ?
     
  14. Babaille

    Babaille Nouveau

    Inscrit:
    17 Avr 2020
    Messages:
    9
    Points:
    0
    Sexe:
    Homme
    Bonjour,

    J'ai essayé d'installer et lancer cette fois Forge 1.7.10

    J'ai lu que cette version de Forge fonctionne sous Java 8 et ai donc suivi le même process que celui indiqué plus haut dans cette discussion (indication du chemin de Java 8 dans la case "Executable Java" du profil Forge 1.7.10)

    Malheureusement cela plante

    Je n'obtiens pas de crash report mais voici le "latest.log" (juste après ma signature)

    Merci par avance
    B.

     
    #14 Babaille, 17 Mai 2020
    Dernière édition par un modérateur: 17 Mai 2020
  15. Babaille

    Babaille Nouveau

    Inscrit:
    17 Avr 2020
    Messages:
    9
    Points:
    0
    Sexe:
    Homme
    Je suis désolé les : suivi d'un p se transforment en smiley :p
     

Partager cette page