1. Si vous venez d'arriver sur le forum et que vous êtes un peu perdus, cliquez ici !
    Rejeter la notice

Problème de lag sur mon serveur "life in the village" (modpack)

Discussion dans 'Problème avec les mods' créé par Paul07, 15 Août 2019.

  1. Paul07

    Paul07 Nouveau

    Inscrit:
    15 Août 2019
    Messages:
    3
    Points:
    0
    Sexe:
    Homme
    Bonjour,

    Voulant jouer avec un ami sur un modpack j'ai fait un petit serveur que je fais tourner sur mon pc en même temps de jouer.
    Mon problème est que le serveur lag dans le sens où quand mon ami ou moi cassons un bloque il met 40 ans à drop, je le vois se tp en se déplaçant... J'ai essayé de mettre mon pc sur ma 4g car ma wifi est pas terrible mais ça n'a rien changé. Cependant après quelques recherches il semble que cela vienne de l'un ou peut-être de plusieurs des mods du modpack qui fais/font baisser le tps (je crois qu'on dit comme ça).

    Pour le modpack j'ai pris pour base ''Life in the village'' disponible sur Curseforge et j'y ai rajouté une quinzaine de mods.

    Voici la liste des mods :

    AE2 Stuff
    AI Improvements
    Akashic Tome
    AppleCore
    AppleSkin
    Applied Energistics 2
    Aquaculture
    AutoRegLib
    Bailey's Dailies
    Baubles
    BdLib
    Better Advancements
    Better Builder's Wands
    Better Questing
    Better Questing - Quest Book
    Better Questing - Standard Expansion
    Better With Lib (BWM - Core)
    Better With Mods
    BetterFps
    BiblioCraft
    Biome Bundle
    Blood Magic
    Botania
    Bountiful
    Chameleon
    Chance Cubes
    Charm
    Chest Transporter
    Chisel
    Colossal Chests
    Comforts
    Compressed Items
    ConnectedTexturesMod
    Controlling
    Cooking for Blockheads
    CoralReef
    Cosmetic Armor Reworked
    CplPibald's Tweaks
    CraftTweaker
    Creeper Confetti
    Cucumber Library
    Custom Main Menu
    Cyclops Core
    Doggy Talents
    Dungeon Tactics
    Ender IO
    EnderCore
    Extra Alchemy
    ExtraCells2
    Fairy Lights
    Familiar Fauna
    Farseek
    FastWorkbench
    FoamFix for Minecraft
    Forestry
    FTB Library
    FTB Utilities
    FTB Utilities: Backups
    Future MC
    Garden Stuff
    Gendustry
    Guide-API
    Hwyla
    Immersive Engineering
    Improved Hoes
    InGame Info XML
    Inspirations
    Inventory Tweaks
    Iron Backpacks
    ItemPhysic Lite
    JourneyMap
    Just Enough Items (JEI)
    Just Enough Resources (JER)
    Landlust - Furniture
    Level Up! Reloaded
    LibraryEx
    Living Enchantment
    LLibrary
    Login Shield
    LunatriusCore
    Mantle
    MegaLoot
    Mekanism
    Mekanism Generators
    Mekanism Tools
    Metamorph
    Millénaire
    Minecolonies
    ModTweaker
    Mouse Tweaks
    MTLib
    NetherEx
    No Mob Spawning on Trees
    No Recipe Book
    Notes
    Open Terrain Generator (OTG)
    Ore Excavation
    OreLib
    Paintings ++
    Pam's HarvestCraft
    Pickle Tweaks
    Ping
    PinklySheep Mod
    Placebo
    Potion Core
    Prefab
    Project: Vibrant Journeys
    Quality Tools
    Quark
    RandomPatches
    Rats
    RealBench
    ReAuth
    Repurpose
    Resource Loader
    Roguelike Dungeons
    Rustic
    Shadowfacts' Forgelin
    Signpost
    Sound Filters
    Spice of Life: Carrot Edition
    StepUp
    stimmedcow : NoMoreRecipeConflict
    Storage Drawers
    Streams
    Terracart Reloaded
    The Aether
    Tomb Many Graves 2
    TombManyGraves 2 API
    TombManyPlugins - Cosmetic Armor Reworked
    Totemic
    Unique Crops
    V-Tweaks
    VanillaFix
    VanillaFoodPantry Mod [FORGE]
    VanillaTweaks
    ViesCraft - Airships!
    Waila Harvestability
    Wawla - What Are We Looking At
    Waystones
    World Primer

    Est-ce que certains de ces mods sont responsables de mon problème ? Ou est-ce que cela vient d'autre chose ?

    Ma config :
    MSI GP73 Leopard 8RE
    GTX 1060 6Go
    Intel Core i7-8750H
    16Go de ram (4Go pour le serveur et 8Go pour le jeu)

    J'espère que vous pourrez m'aider. Merci beaucoup d'avance !
     
  2. robin4002

    robin4002 Support Technique
    Staff

    Inscrit:
    17 Août 2012
    Messages:
    4 934
    Points:
    214
    Sexe:
    Homme
    Bonsoir,
    En effet ce n'est pas un problème de connexion mais un problème de performance, le serveur n'arrive pas à suivre la charge.

    Le fait qu'un mod soit installé ne cause pas de lag en soit, c'est plutôt les éléments des mods sur le monde qui va faire chuter les performances s'ils sont trop nombreux (principalement les entités, donc les animaux, monstre et surtout les tile entity donc les coffres, machines, etc.).
    La liste que tu as envoyé est donc totalement inutile.

    Tu peux utiliser la commande /forge tps pour voir les tps (20 = tout va bien, vitesse normal, 10 = tout est deux fois plus lent, 5 = tout est 4 fois plus lent, etc.).

    Sur Forge il n'a malheureusement pas d'outils pour le debug des performances, en revanche si tu installes Sponge tu pourras générer des timings qui permettent de savoir quelle classe (en gros quelle partie du code) utilise le plus de temps processeur.


    EDIT : je vois aussi que tu as mis bien plus de ram au client qu'au serveur, grosse erreur c'est le serveur qui en as le plus besoin. Alloues-en plus au serveur, il y a des chances que ça aidera.
     
  3. Paul07

    Paul07 Nouveau

    Inscrit:
    15 Août 2019
    Messages:
    3
    Points:
    0
    Sexe:
    Homme
    Bonjour,

    D'accord je vais essayer d'allouer plus de RAM au serveur et d'installer Sponge mais est-ce que pour Sponge je dois désinstaller Forge? Ou est-ce que les deux peuvent être ensemble disons ?
    Aussi je viens de penser, est-ce que le problème ne serait pas dû au fait que je fasse tourner le client et le serveur sur le même pc et que mon processeur ne suive pas pour les deux?

    Merci !
     
  4. robin4002

    robin4002 Support Technique
    Staff

    Inscrit:
    17 Août 2012
    Messages:
    4 934
    Points:
    214
    Sexe:
    Homme
    Sponge s'installe comme un mod forge, donc tu gardes Forge (s'il fallait retirer Forge ça n'aurait pas eu d'intérêt).

    Héberger un serveur sur un pc portable c'est pas le mieux, après le i7-8750H reste un processeur assez performant, donc du moment qu'il n'est pas trop chaud avoir le client et le serveur dessus c'est pas vraiment un problème.

    Mais c'est sûr qu'hébergeur le serveur sur un machine dédié sera mieux.
     
  5. Paul07

    Paul07 Nouveau

    Inscrit:
    15 Août 2019
    Messages:
    3
    Points:
    0
    Sexe:
    Homme
    D'accord, merci pour tes conseils, j'essaye tout ça en rentrant du travail !
     

Partager cette page