1. Si vous venez d'arriver sur le forum et que vous êtes un peu perdus, cliquez ici !
    Rejeter la notice

Problème avec Forge 1.10.2 (Crash)

Discussion dans 'Problème avec les mods' créé par Tsufull, 12 Mar 2017.

  1. Tsufull

    Tsufull Nouveau

    Inscrit:
    12 Mar 2017
    Messages:
    5
    Points:
    2
    Sexe:
    Homme
    Bonjour,
    J'ai installé récemment Forge pour pouvoir tester une map Modée.
    J'étais très enthousiaste, je télécharge Forge bien comme il faut, je prend la version qui me semble la mieux adaptée à mon cas.
    Je constate que le profil "Forge 1.10.2" apparaît bien dans mon Launcher et lorsque je le sélectionne, j'ai un laps de temps qui s'écroule, et au lieu de me lancer avec l'écran de chargement, je me retrouve avec un écran noir qui crash 3 secondes après.

    A savoir que je suis également sur le nouveau Launcher Minecraft et que cela y est peut-être pour quelque chose dans ce problème.
    Je sais que nombreux sont ceux qui ont le même problème que moi mais je ne trouve pas la résolution lorsque je fais mes recherches oO

    Merci de prendre du temps pour ce message et dans l'attente d'une réponse :smile:
    Tsufull.
     
  2. Wanesty

    Wanesty Nouveau

    Inscrit:
    12 Mar 2017
    Messages:
    2
    Points:
    0
    Sexe:
    Homme
    Vérifie la version de Minecraft et de forge que demande les mods.
    Pour t'aider plus il me fraudais un screen des logs de crash..
     
  3. Tsufull

    Tsufull Nouveau

    Inscrit:
    12 Mar 2017
    Messages:
    5
    Points:
    2
    Sexe:
    Homme
    Voici ce que je reçois quand je demande les résultats du crash :

    Code (cpp):
    ---- Minecraft Crash Report ----

    WARNING: coremods are present:
    Contact their authors BEFORE contacting forge

    // My bad.

    Time: 12/03/17 17:07
    Description: Initializing game

    java.lang.VerifyError: Bad return type
    Exception Details:
    Location:
    Config.getDefiningResourcePack(Ljy;)Lnet/minecraft/client/entity/AbstractClientPlayer; @48: areturn
    Reason:
    Type 'net/minecraft/client/particle/ParticleSpell' (current frame, stack[0]) is not assignable to 'net/minecraft/client/entity/AbstractClientPlayer' (from method signature)
    Current Frame:
    bci: @48
    flags: { }
    locals: { 'jy', '[Lnet/minecraft/client/entity/AbstractClientPlayer;' }
    stack: { 'net/minecraft/client/particle/ParticleSpell' }
    Bytecode:
    0x0000000: b803 314c 2bbe 0464 3d1c 9b00 192b 1c32
    0x0000010: 4e2d 2ab9 0367 0200 9900 052d b084 02ff
    0x0000020: a7ff e9b8 0335 2ab6 0368 9900 07b8 0335
    0x0000030: b001 b0
    Stackmap Table:
    append_frame(@9,Object[#804],Integer)
    same_frame(@29)
    chop_frame(@35,1)
    same_frame(@49)


    at java.lang.Class.getDeclaredFields0(Native Method)

    at java.lang.Class.privateGetDeclaredFields(Class.java:2575)

    at java.lang.Class.getField0(Class.java:2967)

    at java.lang.Class.getField(Class.java:1693)

    at net.minecraftforge.fml.client.FMLClientHandler.detectOptifine(FMLClientHandler.java:291)

    at net.minecraftforge.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:203)

    at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:439)

    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:351)

    at net.minecraft.client.main.Main.main(SourceFile:124)

    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)

    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

    at java.lang.reflect.Method.invoke(Method.java:483)

    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)

    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)



    A detailed walkthrough of the error, its code path and all known details is as follows:
    ---------------------------------------------------------------------------------------

    -- Head --
    Thread: Client thread
    Stacktrace:
    at java.lang.Class.getDeclaredFields0(Native Method)
    at java.lang.Class.privateGetDeclaredFields(Class.java:2575)
    at java.lang.Class.getField0(Class.java:2967)
    at java.lang.Class.getField(Class.java:1693)
    at net.minecraftforge.fml.client.FMLClientHandler.detectOptifine(FMLClientHandler.java:291)
    at net.minecraftforge.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:203)
    at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:439)

    -- Initialization --
    Details:
    Stacktrace:
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:351)
    at net.minecraft.client.main.Main.main(SourceFile:124)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:483)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)

    -- System Details --
    Details:
    Minecraft Version: 1.10.2
    Operating System: Windows 8.1 (amd64) version 6.3
    Java Version: 1.8.0_25, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 127060072 bytes (121 MB) / 268857344 bytes (256 MB) up to 1060372480 bytes (1011 MB)
    JVM Flags: 6 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx1G -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn128M
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    FML:
    Loaded coremods (and transformers):
    Launched Version: 1.10.2-forge1.10.2-12.18.2.2099
    LWJGL: 2.9.4
    OpenGL: AMD Radeon HD 8330 GL version 4.2.12420 Compatibility Profile Context 13.151.0.0, ATI Technologies Inc.
    GL Caps: Using GL 1.3 multitexturing.
    Using GL 1.3 texture combiners.
    Using framebuffer objects because OpenGL 3.0 is supported and separate blending is supported.
    Shaders are available because OpenGL 2.1 is supported.
    VBOs are available because OpenGL 1.5 is supported.

    Using VBOs: Yes
    Is Modded: Definitely; Client brand changed to 'fml,forge'
    Type: Client (map_client.txt)
    Resource Packs: §lMathoX 8x8 Pack§0.zip (incompatible)
    Current Language: ~~ERROR~~ NullPointerException: null
    Profiler Position: N/A (disabled)
    CPU: 4x AMD A4-5000 APU with Radeon(TM) HD Graphics
     
    #3 Tsufull, 13 Mar 2017
    Dernière édition par un modérateur: 13 Mar 2017
  4. Calambiel

    Calambiel Résident de l'End

    Inscrit:
    5 Août 2014
    Messages:
    6 595
    Points:
    229
  5. robin4002

    robin4002 Support Technique
    Staff

    Inscrit:
    17 Août 2012
    Messages:
    5 402
    Points:
    229
    Sexe:
    Homme
    Salut,
    Vérifies que tous les mods dans ton dossier mods sont bien compatible avec la version 1.10.2 car ça ne semble pas être le cas.
     
  6. Tsufull

    Tsufull Nouveau

    Inscrit:
    12 Mar 2017
    Messages:
    5
    Points:
    2
    Sexe:
    Homme
    J'ai téléchargé les mods d'un mod pack tout pret pour la map.
    Cette map c'est pour "Stranded Forever". Dans le .zip je n'ai fait que télécharger tout ce qu'il y avait dans le mod pack et normalement tout est fait pour la 1.10
    Mais mon Forge ne se lance pas :/
     
  7. robin4002

    robin4002 Support Technique
    Staff

    Inscrit:
    17 Août 2012
    Messages:
    5 402
    Points:
    229
    Sexe:
    Homme
    Vu le message d'erreur j'ai de gros doute quand au fait que tous les mods que tu as sont compatibles avec ta version de minecraft.

    Il y avait peut-être un mod d'une autre version qui était déjà présent que tu as mis les mods du modpack et qui est resté avec.
     

Partager cette page