1. Si vous venez d'arriver sur le forum et que vous êtes un peu perdus, cliquez ici !
    Rejeter la notice

Résolu Problème lors des commandes gradlew

Discussion dans 'Aide à la création de mod' créé par SkoZSmorth, 12 Août 2018.

  1. SkoZSmorth

    SkoZSmorth Nouveau

    Inscrit:
    12 Août 2018
    Messages:
    4
    Points:
    0
    Sexe:
    Homme
    Bonjour/Bonsoir,

    Je suis à la base un créateur de plugins, mais il y'a peu je me suis dit que ce serai sympa de créer un mod.
    Alors je me suis basé sur certains tutoriels et j'ai téléchargé les src de forge en 1.7.10. A ce moment là plein de problème sont apparus par exemple; je n'arrivais pas à ouvrir l'invité de commande directement dans le fichier du coup fallait mettre cd et après le chemin bref un problème basique pour l'instant, j'ai donc voulu exécuter la commande "gradlew setupDecompworkspace" puis il m'a dit que j'avais un problème de version donc j'ai désinstallé java, et là un autre problème (avec la même commande "gradlew setupDecompworkspace"):

    ERROR: JAVA_HOME is not set and no 'java' command could be found in your PATH.

    Please set the JAVA_HOME variable in your environment to match the
    location of your Java installation.

    Mais celui-ci je n'arrive vraiment pas à le résoudre, je ne le comprend pas.

    Informations:
    Je crée un mod en 1.7.10
    forge-1.7.10-10.13.4.1558-1.7.10-src (2)
    Je suis sous windows 10

    Priant d'avoir rapidement une réponse,
    Merci.
     
  2. pifou92000

    pifou92000 Mineur de Diamants

    Inscrit:
    23 Juin 2011
    Messages:
    2 686
    Points:
    195
    Sexe:
    Homme
    Salut, déjà tu dois installer le JDK, si tu ne l'as pas fait.
    Ensuite tu dois changer la variable d'environnement JAVA_HOME pour indiquer le répertoire d'installation du JDK. Pour cela, va dans les paramètres système avancés, et sélectionne "variables d'environnement". Tu peux trouver des tutos sur le Web.
     
    • J'approuve J'approuve x 1
  3. SkoZSmorth

    SkoZSmorth Nouveau

    Inscrit:
    12 Août 2018
    Messages:
    4
    Points:
    0
    Sexe:
    Homme

    Bonjour/Bonsoir

    Merci de cette réponse,

    Lors de l'opération je suis tombé sur un nouveau problème:

    En premier j'ai fait:
    Paramètre ensuite je suis aller dans le truc paramètres système avancés ensuite je suis aller dans variables d'environnement puis je suis aller dans variables système et j'ai fait nouvelle ensuite j'ai créer mon chemin vers l'installation de mon jdk, puis j'ai refait le commande "gradlew setupDecompworkspace"

    et là voici l'erreur:
    (C'est aller jusqu'à 98%)

    :makeStart FAILED

    FAILURE: Build failed with an exception.

    * What went wrong:
    Execution failed for task ':makeStart'.
    > Unable to find a javac compiler;
    com.sun.tools.javac.Main is not on the classpath.
    Perhaps JAVA_HOME does not point to the JDK.
    It is currently set to "C:\Program Files (x86)\Java\jre1.8.0_131"

    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

    BUILD FAILED
     
  4. robin4002

    robin4002 Support Technique
    Staff

    Inscrit:
    17 Août 2012
    Messages:
    4 736
    Points:
    204
    Sexe:
    Homme
    • J'approuve J'approuve x 1
  5. SkoZSmorth

    SkoZSmorth Nouveau

    Inscrit:
    12 Août 2018
    Messages:
    4
    Points:
    0
    Sexe:
    Homme

    Re,

    C'est bon ça marche super !
    j'ai trouver le jdk
    Je ne mets pas le poste en résolu car je n'ai encore testé toutes les autres commandes

    Merci !
     
  6. SkoZSmorth

    SkoZSmorth Nouveau

    Inscrit:
    12 Août 2018
    Messages:
    4
    Points:
    0
    Sexe:
    Homme
    Hey,

    Je parle maintenant à ce qui n'ont pas compris et qui ont eu le même problème que moi:

    Pour le premier problème:

    ERROR: JAVA_HOME is not set and no 'java' command could be found in your PATH.

    Please set the JAVA_HOME variable in your environment to match the
    location of your Java installation.

    Il va vous falloir installer le jdk (Java development kit)

    Maintenant allez dans vos paramètre (vous appuyez sur le touche windows de votre clavier, puis allez dans les paramètres)
    Dans Rechercher un paramètre tapez système avancés ensuite cliquez sur Afficher les systèmes avancés
    En bas vous avez "Variables d'environnement..." cliquez dessus vous avez ensuite Variables système
    Cliquez sur Nouvelle...
    Donnez un nom à votre variable puis cherchez le chemin d(installation de votre JDK (Java development kit)
    Dans le fichier choisissez bien le JDK et pas le jre !

    Maintenant réessayez et ça devrait marcher !
     

Partager cette page